なんだこれは;

Microsoft Windows Common Controlsって
ありますよね。
あれ、バージョン6とか5とか
あるんですが、当然
バージョン6の方が新しいはずですよね。
実はこの、バージョン5の方は
「COMCTL32.OCX」を使っていて、
バージョン6の方は「MSCOMCTL.OCX」を
使っているんですが、
WindowsXPのCommonControl6を使いますよと
Manifestファイルに記述して
リソーススクリプトに含めたときに
なぜかバージョン6だと無視されます。
なんでですか;;;
しかも、それだけではありません。
なんでバージョン5で適用されてるの;
いや、マジなんでやねん;;
一説によれば、バージョン6のコントロールは
本物のCOMCTL32を使っていなくて、
擬似コントロールでできているのでは、
なんて言われているのを聞いたことが
ある気がします。
誰か詳しいことを知っている方がいましたら
教えて欲しいです;;

You may also like...

コメントを残す

メールアドレスが公開されることはありません。